Spike Camp

20 ga element waterfowl issues!! Help!!

20 ga element waterfowl issues!! Help!!
« on: July 14, 2017, 05:56:04 PM »
I bought a 20 gauge element waterfowl shot gun for my 12 year old son to use for Ducks and for sporting clays. It has not been cycling very well so far. It will shoot the first round and will either not eject or not load the next shell. Has anyone had this issue? I have cleaned the gun throughly and have had our local club pro look at it and it seems that the carriage does not lift the shell up to the breech in time to be loaded??  Any help would be appreciated!!

Re: 20 ga element waterfowl issues!! Help!!
« Reply #1 on: July 14, 2017, 06:10:00 PM »
Welcome to the Nation!! I'd suggest you check back thru previous threads to see if any one else has had a similar problem. I seem to remember someone did and they contacted the Weatherby Service department and got help. I don't own an element, but I do know Weatherby can't be beat for helping their customers. Hopefully someone chimes in, otherwise try my previous suggestions.
Doug

Re: 20 ga element waterfowl issues!! Help!!
« Reply #2 on: June 07, 2021, 01:52:15 PM »
I'm having the same issue with an Element 20 ga. No matter what brand ammo I use, it fails to feel 80% of the time, leaving the next round to be loaded resting on top of the loading gate.
I sent Weatherby an email Sunday (6/6/21) but have yet to hear back from them today (Monday 6/7/21).
If I dont hear back in a couple days, I'll call them.
I read a post here dated back to 2016, that the OP had this same issue and Weatherby had someone monitoring the forum for issues, and picked up the question and contacted the user.
In that case, they wound up replacing the gun, but the OP had to ship the gun back to them for evaluation.

http://weatherbynation.com/index.php?topic=14452.0
« Last Edit: June 07, 2021, 01:58:33 PM by cwickgo9 »